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Using GIS applications for field mapping – An 
introduction 
This workshop will provide training in effective field mapping and GIS analysis using 
contemporary technology. With the advent of GNSS (Global Navigation Satellite Systems) 
integrated into smartphones, researchers can now systematically document field data, 
including accurate measurements, photographic evidence, and geolocation information. This 
capability facilitates robust analysis within Geographic Information Systems (GIS), thereby 
enriching research across diverse disciplines such as botany, ecology, archaeology, and urban 
studies. 

Accurate field observations are critical for many field-based disciplines and serve as a 
foundation for innovative analytical methodologies. With skills in how to use this technology 
efficiently, researchers can significantly enhance their data collection and analysis processes. 

As a leading open-source Geographic Information System (GIS) software, QGIS is the go-to tool 
for spatial analysis and mapping. This workshop will cover the use of QGIS in combination with 
mobile apps, QField and OSMAnd, to prepare for mapping in field and to manage, edit and 
visualise features mapped in field. 

The materials provided for mapping include the following parts: 

1- Introduction to QGIS 

2- Field mapping with OSMAnd 

3- Field mapping with QField 

4- Import field data and make your own field map  

5- QField – More to know 

Software used in the course 
For the workshop you need the following software 

• QGIS – mapping software to display, analyse and visualize geographical data.  
• OSMAnd – mobile app for mapping in field. It has important functionality like adding 

waypoints, track movements and adding notes, pictures, sound and videorecodings. No 
previous set up required before field work. However, data collected in field will most 
probably need editing and be supplemented with analog notes before final analysis and 
visualization in QGIS.  

• QField – mobile app for mapping in field. It has important functionality like adding 
waypoints, track movements and adding notes, pictures, sound and videorecodings. 
Used in combination with QGIS highly customized field survey forms can be designed in 
advance of fieldwork. This requires basic GIS skills that you will have the opportunity to 
learn in this course. When field data is imported back into QGIS after field work it will 
contain all recorded attributes and be ready for further analysis and visualization. 
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Installation of QGIS 

For the workshop, please, install QGIS 3.34 Long Term Release (LTR).  

https://www.qgis.org/en/site/forusers/download.html# 

The LTR versions of QGIS offer stability and are supported with bug fixes and security updates 
for a longer period, making them ideal for professional use. Here's a simple step-by-step guide 
to get you started: 

Visit the Official QGIS Website: 

Start by navigating to the QGIS official website: www.qgis.org. 

The LTR version is prominently featured and recommended for most users, especially those 
seeking stable environments for their GIS projects. 

Choose Your Platform: 

QGIS is versatile and available for various operating systems including Windows, macOS, and 
Linux. 

Click on the appropriate download link for your operating system. 

Download and Install: 

For Windows, you will have options like 'Standalone Installer' or 'Network Installer'. Choose the 
Standalone Installer for a straightforward setup. 

Follow the download instructions, which typically involve running an installer file. During the 
installation process, you can choose default settings or customize the installation based on 
your preferences. 

Launch QGIS: 

Once the installation is complete, launch QGIS from your applications menu or desktop 
shortcut. 

Upon opening, you might be prompted to install additional components or plugins. You can 
choose to do this immediately or explore these options later. 

Should you encounter any problems during the installation process, one helpful resource might 
be the following installation guide:  

https://www.qgis.org/resources/installation-guide  

Installation of OsmAnd 

 
 

https://www.qgis.org/en/site/forusers/download.html
https://www.qgis.org/resources/installation-guide
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Download maps 

The OsmAnd app works with different types of maps, but it can only function fully with 
downloaded offline maps, so after the Get started screen you are prompted to download map of 
your region. You can choose a different region, restore from OsmAnd Cloud, or skip this step and 
download maps later. 

Download maps is a necessary action for further using map and navigation in offline mode. 
Maps can be downloaded both by browsing through the regions list from the main menu and by 
clicking on the needed territory on the map. 

The files are updated monthly based on OpenStreetMap. Searching files by address, name or 
coordinates offline is supported. 

Installation of QField 
Search for and install QField from google play or an app store of your choice.  

Make an account on QFieldCloud when you have installed the app. From the first page you meet 
opening the app, choose QFieldCloud projects, and then “Register an account”. Fill the 
registration form and confirm your email before you try to log in.  

Data for the course  
Data for the workshop practicals is found in the folder “Data” that you will be copying from a hard 
drive that the instructor will share with you. This instruction is found in the “Documents” folder 
under Data. 

Make a folder on your laptop/computer called SNAC_workshop where you store all the material 
from the workshop. Copy the entire Data-folder to SNAC_workshop folder. Save everything you 
generate during the workshop in this folder.  

 

Note: OsmAnd cannot work correctly without downloaded offline maps. 
Although the application supports Vector and Raster maps, it is strongly 
recommended to start working with vector offline maps to make all functions 
such as Search, Navigation, and Context menu work properly. 
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1. Introduction to QGIS 
What you will learn: 

- Start QGIS 3.34 LTR (long-term release) 
- Create a new map 
- Add data layers 
- Pan and zoom 
- Change data symbology and display properties 
- Select data 
- Measure distances 
- Create map layouts 
- Add legends, titles, North arrows, and other elements 
- Print a map to a PDF 

What you’ll produce 

Two maps: one of lakes and roads and one of wetlands.  

Start QGIS and add data 
First, find the QGIS icon, shown to the right. The icon is often located 
as a desktop or taskbar shortcut, or in a QGIS folder. In Windows 7 or 
10 it may often by found by left clicking on the Start button in the 
lower left of the screen and selecting QGIS 3.34  → QGIS Desktop 3. 
3.34. 

This will open the main QGIS 
window. You create a new, empty 
project by clicking on the very left 
menu Project → New. 

• We immediately save the 
new project via Project → 
Save As.  

• Make sure to save the 
project in the 
SNAC_workshop directory 
and give it a proper name 
(e.g. “Proj1”)! 

 

 

 

You now see the main window of QGIS, as shown below. It contains quite a few components, 
including the menu bar at the top, a few more rows below with many icons, the Browser and Layer 
filed on the left as well as the Processing Toolbox on the right. Hint: The functionality, i.e. amount 
of icons in the upper rows is subject to additional plugins, so don’t be confused if you don’t see 
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the exact same icons as shown. Moreover, the Processing Toolbox can be hidden; click on 
Processing → Toolbox to activate it. 

 

Now we will focus on adding and displaying data. As an example, we insert a basic 
OpenStreetMap. In the browser go on XYZ Tiles → OpenStreetMap. There is also the option to add 
Google Maps Satellite Images. 

 

You can pan about the map by using the Pan Map function, which can be found in the first row. 
Adjacent, there are two magnifier symbols to zoom in and zoom out. By left-clicking on the map 
and hold-dragging on the map you can pan the map; zooming also works if you have a mouse with 
a mouse wheel. You can also play around with the other zoom/pan-tools: 
Next to the pan function you can zoom to a selected area, the icon on the 
far right zooms out entirely. 

Browser 

Layers 

Processing 
Toolbox 
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Click on the check box next to the OpenStreetMap layer, and note they toggle the layers’ visibility 
on and off.  

For now, we are removing this layer by left 
clicking on it and selecting Remove Layer, which 
is the far right icon in the Layers window. 

 

Now, we are using some data. Click on Layer → Add Layer → Add Vector Layer. 
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This will open the Data Source Manager window where you need to select the source of the data 
you would like to add. Click on the three dots in this window, navigate to the folder where you 
stored the data related to this exercise and choose lakes.shp and roads.shp 

 

 

 

If you click on Add in the Data Source Manager window, most likely a window will appear that 
prompts you to decide on an issue concerning different coordinate systems. The coordinate 
system of the OpenStreetMap that we used earlier is EPSG 3857 (WGS 84 / Pseudo Mercator), and 
QGIS assumes you would like to continue working in this coordinate system. The input data 
belongs to another reference system (UTM zone 15N), so QGIS suggests transforming the data 
into the destination CRS of the OpenStreetMap. However, we do not want that, because we are 
going to work in the coordinate system of the input data (EPSG 26915). Click on Cancel. 
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You can now close the Data Source Manager window. 

This will add this data to your project and it appears in the middle of the QGIS window. 
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There are also useful tools along the bottom of the main window, see above. The coordinates (X, 
Y) are provided on the very left. Next to that is the nominal scale, which can be selected via the 
dropdown menu by clicking on the arrow, or by typing one in directly. The magnifier shows the 
current zoom level; the rotation can be found adjacent. On the far right you see the coordinate 
reference system, which is in our case based on the just imported shapefiles. If you click here, a 
window will open, where you can select a different coordinate reference system for your entire 
project. 

Changing Layer Symbology 
We can customize a layer’s appearance. Right click on the roads layer we just imported, and 
navigate to Properties, then to Symbology. 

 

 

On the top of the window you can choose 
the general type of symbol, which is in our 
case just a single symbol. If you open the 
dropdown menu (see red arrow on the 
right picture on the previous page), you 
can see all types that are available (shown 
at right). This is especially useful when 
working with categorized data. The 
symbology is currently set to single 
symbol and we will leave it like this for 
now.  

In the lower part of the window you can 
apply different settings to the line, i.e. its 
color, opacity and width. If you click on the 
color field (indicated by upper red arrow) 
another window will open, where you can 
specify the desired color. 
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Moreover, you can define the appearance of 
the symbol by opening the Style Manager 
(indicated by lower red arrow). Here, it is 
possible to choose the appearance of the 
symbol out of a huge variety provided in 
different tabs (shown to the right). Although 
there are many options you can set, for now 
just choose black as color and 1 as width to 
specify roads. 

 

 

Repeat this process for the lakes layer, 
specifying a light blue interior, and darker 
blue boundary for the lakes. Hint: if you 
have opened the Symbology tab in the 
Properties of the lakes’ layer, you need to 
left click on the actual fill type in order to 
set the fill and stroke color (shown to the 
right). 

 

 

 

 

Now, your map should look something like 
the image below. 

 



SNAC workshop – Field mapping and GIS 

11 
 

Inspect attribute table 
So far you have become familiar with the geometrical objects of the roads and lakes shape-files. 
As explained in the video material, geographical data consists of not only the geometry of the 
objects but also a description of what the geometrical objects are. This information is stored in 
an attribute table. You can click on any object in the map window and see its description from 
the attribute table. Choose the “identify features” tool and click on a lake or a road. A window 
called “identify features” will appear.  

  

Another way to the see the attribute information is by selecting the layer of interest in the layers 
panel, right click and select “open attribute table”. For the lakes the table looks like this 

 

It contains information about the area and perimeter of the lakes as well as some other 
information, for instance the LAKES_ID that is an unique identifier for each object. You can sort 
each column in increasing or decreasing order by clicking on the column name. If you select a 
row, the corresponding object will be highlighted in the map window.  

 

 

Create a Layout 
We often wish to create a map depicting our data, plus information such as title, legend, north 
arrow, and a scale bar. In GIS software, such a map is called a map layout, and it is a way of 
organizing and presenting geographic information in a clear and visually appealing manner. It 
involves arranging the necessary map elements on a page, such as: 

• the map itself, 
• grid 
• legend, 
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• scale bar, 
• title, 
• north arrow, 
• source (CRS). 

The layout is carefully planned to ensure clarity, readability, and to accurately convey the 
intended message or data to the map's audience. It's an essential part of map-making that 
focuses not just on showing geographic locations, but also on making the map easy to use and 
understand. 

To do this here, first create a new Print Layout by clicking 
on the indicated symbol in the first row of icons. QGIS 
prompts you to insert a title for your map. Choose a proper 
name, e.g. Proj1_Hugo_Lakes-Roads.  

A new window pops up showing an empty canvas. Make 
sure to set the layout to landscape, because our data is rather wider than tall. Click on Layout, 
scroll down to Variables and check whether layout_pagewidth equals 297 and layoutpageheight 
equals 210 (see picture below). 

 

If that is not the case, change the layout by right clicking on the empty canvas in the middle, and 
navigate to Page Properties (shown underneath). 

This will open the Item Properties 
on the right next to the Layout 
window itself. Here, you can 
choose the orientation, where we 
set it to Landscape. 

 



SNAC workshop – Field mapping and GIS 

13 
 

Now, we add a map via the icon on the left side like shown below. Left click on the empty canvas 
and drag the size of the map. Afterwards, the lakes and roads will appear.  

 

Now, your map should look something like the image below  

 

It is advisable to change the scale of the map, 
because there is a huge white boundary that does not 
contain any information. Check the scale of the map in 
the Item Properties window (picture to the right). If you 
compare this to the scale in the QGIS main window, it 
probably differs. Adjust the scale in the Print Layout so 
that the white boundary shrinks. You can also use the 
Move item content function (toolbar on the far left 
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side) to move only the content of the map within the frame. Finally, drag the frame as big as 
necessary. 

 

 

We add the most common layout elements such as  

• a north arrow,  
• a scale bar,  
• a legend and  
• a descriptive text.  

Let’s start with the north arrow. To add new 
elements to the map, we go to Add Items in the 
main menu on top of the window. Then, click on 
Add North Arrow. Hint: adding a north arrow is also 
possible by clicking on the corresponding icon in 
the icon list on the left side. 
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You can now drag a frame that will contain the north arrow like shown beneath (red arrow / red 
box). 

 

You should see a default north arrow in the box you just created. Note this new element in the 
Items list on the top right of the window. You can choose from different types of north arrows like 
shown below (blue box).  
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We also would like to add a 
scale bar. You can click on the 
Add Scale Bar icon or go to the 
drop down menu Add items → 
Add Scale Bar. You can drag the 
desired size of the scale bar and 
place it in the main window 
(picture on the far right). 

 

 

Formatting a scale bar is a bit more complex than a 
north arrow. Open the Item Properties to see what 
we can set. In the Main Properties you can decide to 
which map it should be linked. Moreover, you can 
specify the Style. We keep the current settings, but 
it is useful to keep these things in mind, especially 
if you are working with more than one map. Below 
we can set the Units, e.g. kilometers. Depending on 
the scale of the map, it might be necessary to adjust 
it. 

You can also change the appearance of the 
Segments, e.g. amount, position and width. 
Currently, there are two segments on the right side. 
Decide on a proper way according to your map / 
data you want to present. For instance, a Label unit 
multiplier of 1, increasing the number of segments 
to 5 with a fixed width of 1 units will result in the 
following scale bar: 

 

Hint: the scale bar is of course linked to your map and therefore 
to its scale. The scale bar changes dynamically when changing 
the scale of the map. In this example, the shown scale bar is 
subject to a map scale of 1:50,400. 

It is also advisable to change the font, as the default is too small 
in most cases. Scroll down to Display in the Item Properties 
window of the scalebar. 

Make sure your scalebar is properly formatted. The primary 
criteria are readabilty and clarity. The default is often placed with 
too small font, or odd break values. 
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Most maps need a legend as well. You find the correct tool in the left 
toolbar: Clicking on the Add Legend tool activates the cursor as a crosshair, 
and allows you to click-drag on the layout to place a legend. 

 

Again, choose a proper format for your legend (i.e. increase the font). Hint: in the Item Properties 
window of the legend scroll down to Fonts and Text Formatting. 

Now add a title to your map  (use Add Label on the 
left toolbar to do so). Change its text as well as font and 
size in the item’s properties You can add your name in the 
same manner.  

Make sure your map has a title, legend, north arrow, 
and a scale bar. These elements should be reasonable 
and well-positioned. 

Your layout should look something like the image below, 
but you don’t have to match it exactly of course. Just make 
sure to include the required elements, listed above. We 
encourage you to use different fonts, colors, north arrow, 
and a scale bar, or at least peruse what are available. 
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Export map as a PDF file 
Let’s export the map to a PDF file. Click on the Export as 
PDF… icon in the toolbar on top.  

 

You will be asked to give a file name; choose a 
proper name e.g. Proj1_Hugo_Lakes-Roads.pdf 
and save the file in the directory of your project. 
After clicking on Save, QGIS opens a new 
window where we can set the PDF Export 
Options. 

QGIS offers to save the file as Geospatial PDF. It 
is not necessary, but at least useful to save it as 
GeoPDF. Basically, a GeoPDF is like a normal 
PDF file. However, it contains additional 
functionality. A GeoPDF directly saves the 
spatial coordinates of the area / map. 
Accordingly, the file is immediately assigned to 
its correct locations. PDF software like Adobe 
Reader has special tools to measure distances, 
which can be used if the file is a GeoPDF. 

It is advisable to remove the tick at the bottom 
so that QGIS don’t simplifies geometries to 
reduce the output file size. 

Note: every setting is dependent on your 
specific task and desired result. If your map is very complex, i.e. it contains many layers in a high 
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resolution, it can also be useful and time saving to simplify geometries and / or save it as normal 
PDF! 

We keep all other settings. Click on Save, if you are done. Also, remember to save your project 
frequently while working. Save and close your project. 

Symbolize Categories 
You just learnt how to make a map and symbolize simple features. In this section you will learn 
how to symbolize features that have different categories. 

Create a new project named something like “Wetlands_proj” and add the layer “wet_land.shp” 
from the project directory. This layer shows polygons for wetlands near Hugo, Minnesota. Hint: if 
you are unsure how to add the layer, check the previous assignment. In case QGIS wants to 
transform coordinates between different reference systems, cancel this step. You should see 
something like this underneath: 

 

 

Right click on the wet_lands layer, go to 
Properties → Symbology. Click on the 
dropdown-menu at the top of the 
window to apply Categorized symbology. 

 

Choose WETLAND_TY in the dropdown 
menu of Value.  
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There are no values yet, because they first 
need to be classified. Therefore, click on 
Classify at the bottom of the page. 

The assigned color scheme is displayed 
for each category (see at right). You often 
have a large number of categories and 
want to change colors for some of them. 

 

 

 

 

 

 

Let’s assign the lakes (L) a blue color, and since the U-value (which means uplands) is such a large 
part of the map let’s apply a rather bright color to make the map more readable. Mark the L-value 
in the table of symbols and click on the color field on top of the window (red arrow). 

 

 

Another window will pop up showing the color 
properties of L. For now, we’ll choose a light blue 
lake color, and a darker blue outline for the lakes 
and keep the outline width as is. Hint: to be able 
to change the color click on the color field 
(indicated by red arrows). Apply by clicking on 
OK. 

 

Now, let’s assign another color to the uplands (U symbol) as well. It’s the same procedure: click 
on U in the list like shown above, open its properties and adjust the fill and stroke color. We would 
like the Stroke color to be transparent. Hint: click on the dropdown menue (red arrow) and activate 
Transparent Stroke. The fill color could be in a light tan color. 
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Your map should look something like the figure 
below. Don’t worry if your wetlands polygons are a 
different color, just make sure the lakes and 
uplands are assigned correctly. 

 

Save the project with your data, close it and 
continue with the instructions below. 
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Adding basemaps via plugins 
There are different ways to add basemaps to your project. You have already seen how to add 
from the XYZ-tiles option. You can also add via plugins, i.e. small program additions to QGIS. A 
very convenient one is the QuickMapServices plugin.  

To activate it, navigate to Plugins → Manage and install plugins. Via the header Not installed 
→ search for Quick map services in the search bar. 

 

Click on “Install”. After it installed, you should be able to find QuickMapServices button in the 
Web Toolbar 

 

Click on the left button and navigate to Settings in the drop-down menu. From here, go to “More 
services” and click on Get contributed pack. In the adjacent Visibility tab you can choose 
which basemaps you want to turn on and off.  

Save your changes. 

Installation of Plugins needed for the Workshop 
In the following section we will install another two Plugins that will be needed during the course.  

Navigate to Plugins → Manage and Install Plugins. Via the header “Not installed”, search for 
QField Sync and click on Install Plugin.  

Do the same for QMeta Tiles.  
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About Project Properties 
QGIS offers a range of settings to adjust several properties of your 
project. Let’s check this out. Go to Project → Properties. 

These settings are related to your entire project. You can, i.e. adjust the 
properties of the measurements such as the units for distance and area 
measuring. 

There are also other interesting tabs like CRS and Transformations. 
These two are related to the coordinate reference system of your 
project. Make yourself familiar with these Project Properties. 

 

About  Shapefiles 
You may wonder about the data layers you have used for your maps, e.g., Lakes, Roads, and 
vegetation. These layers are shapefiles, an early format defined by ESRI for storing spatial data, 
and now a common standard for distributing and saving spatial layers. 

A shapefile is actually a cluster of files. You can see this below. In the first picture you can see the 
layers window of the previous project. Here, the vegetation layer consists of one file 
(vegetation.shp). However, if we take a look at the file directory in Windows Explorer (blue frame, 
picture on the bottom), we can see several files with the name vegetation, each with different 
extensions. In addition to the .shp, there is a .dbf, .prj, .shx, and others. A complete shapefile is 
made up of several files, at a minimum a .shp, .shx, and .dbf files. If you ever copy shapefiles using 
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File Explorer or another generic file management tool, you need to copy ALL THE FILES, NOT JUST 
THE .SHP FILE. Otherwise, your copy will likely be incomplete, and useless. 

 

 

 

Later in the course you will learn about the geopackage format. This is a database format. 
Databases allow you to store large amounts of data in one file. Thus they can be very helpful for 
GIS applications.  

Unlike Shapefiles, GeoPackages can contain more than one data type (vector and raster, as well 
as tables) and these even in different coordinate systems! 

Some free GIS-data 
Here are a few examples for free GIS data, that may be interesting for some future projects. 

Free GIS Data for Globe: https://freegisdata.rtwilson.com/  

Africa Specific Data: https://digital-africa.co/en/ 

Data link: https://docs.digitalearthafrica.org/en/latest/data_specs/index.html#elevation 

 

More data is available via ESRI Africa Geo Portal: https://www.africageoportal.com/  

You have now learnt important basics in QGIS. In the next sections you will be introduced to 
the field mapping apps OSMAnd and QField and how these can be used in combination with 
QGIS to make field mapping more convenient and efficient. 

  

https://freegisdata.rtwilson.com/
https://digital-africa.co/en/
https://docs.digitalearthafrica.org/en/latest/data_specs/index.html#elevation
https://www.africageoportal.com/
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2. Field Mapping with OsmAnd 
About OsmAnd 

• OsmAnd (OpenStreetMap Automated Navigation Directions) is an 
application for maps and navigation based on OpenStreetMap data.  

• OsmAnd is a versatile, open-source map and navigation application 
available for Android and iOS devices.  

• It leverages data from OpenStreetMap (OSM) to provide detailed, 
offline maps and navigation services. 

• One of the best navigation Apps for smartphones. 
 

 
 

Key features 
• Offline Maps: Download and store maps for any region worldwide, 

enabling navigation without an internet connection.  
• Navigation: Offers turn-by-turn voice guidance for various modes of 

travel, including driving, cycling, walking, and public transportation. 
Features like lane guidance, street name display, and estimated time 
of arrival enhance the navigation experience. 

• Map Customization: Choose from different map styles tailored for 
activities such as touring, nautical navigation, skiing, and off-road 
adventures. Overlay multiple map sources and adjust transparency 
to suit your preferences.  

• Points of Interest (POIs): Access a vast database of POIs, including 
attractions, restaurants, health facilities, and more. Search by 
address, name, coordinates, or category.  

• Route Planning and Recording: Plan routes with multiple waypoints, 
record GPX tracks, and manage them within the app. Visualize route 
data such as elevation changes and distances.  
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• OpenStreetMap Integration: Contribute to OSM by editing maps, 
adding POIs, and uploading GPX tracks directly from the app.  

• Versions and Pricing: 
• Free Version: Provides access to core features 

 

Begin with OsmAnd 
• Install OsmAnd 

 
 

• Download maps 
The OsmAnd app works with different types of maps, but it can only 
function fully with downloaded offline maps, so after the Get started screen 
you are prompted to download map of your region. You can choose a 
different region, restore from OsmAnd Cloud, or skip this step and 
download maps later. 
 
Download maps is a necessarily action for further using map and 
navigation in offline mode. Maps can be downloaded both by browsing 
through the regions list from the main menu and by clicking on the 
needed territory on the map. 
 
The files are updated monthly based on OpenStreetMap. Searching files by 
address, name or coordinates offline is supported. 

 
 

Note: OsmAnd cannot work correctly without downloaded 
offline maps. Although the application supports Vector and 
Raster maps, it is strongly recommended to start working with 
vector offline maps to make all functions such as Search, 
Navigation, and Context menu work properly. 
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Get access to all features via main Menu  

 
 

Marking a Point (Waypoint) 
1. Open OsmAnd on your device. 
2. Navigate to the location on the map or let OsmAnd detect your 

current location. 
3. Add a Marker: 

o Long-Press on the Map: Tap and hold the location where you 
want to add a point. A pin or marker will appear. 

o From Current Location: 
▪ Tap the "My Location" button (usually a circle with a dot). 
▪ Once the map centers on your location, long-press on 

the blue marker. 
4. Save the Point: 

o Tap on the marker that appeared. 
o Select Save Point or Add to Favorites (the option depends on 

your OsmAnd version). 
o Name the point for easy identification later (e.g., "Farm Field 1" 

or "Water Source"). 
5. Managing Saved Points 

o Go to Menu → Favorites or Saved Places to view all your 
marked points. 

o You can edit, delete, or navigate to any saved point. 
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Go to point 
1. Open OsmAnd 

• Launch the OsmAnd app on your device. 
 
2. Search for Your Location 
You can search for a location in several ways: 

• By Name: Tap the Search icon (magnifying glass), enter the name of 
the place, and select it from the results. 

• By Coordinates: 
1. Tap Search → Categories → Coordinates. 
2. Enter the latitude and longitude of the desired location. 

• By Point on the Map: 
1. Long-press on the map where you want to go. 
2. Select Navigate to Here from the popup menu. 

 
3. Plan the Route 

• After selecting the destination, tap Directions or Navigate. 
• OsmAnd will calculate the route based on your current location (or a 

manually set starting point). 
 
4. Adjust Navigation Settings 

• Choose your transport mode (e.g., walking, driving, cycling). 
• Set preferences: 

o Avoid toll roads. 
o Prefer shortest/fastest route. 



SNAC workshop – Field mapping and GIS 

29 
 

o Enable voice guidance. 
 
5. Start Navigation 

• Tap Start to begin navigation. 
• Follow the turn-by-turn instructions and the map display. 

 
6. Offline Navigation 
If you're navigating offline, ensure: 

• You have downloaded the relevant map for the region under Menu → 
Download Maps. 

• Offline routing is enabled. 
 

       
 

Tracking 
To create a track in OsmAnd (record your movement or define a route), 
follow these steps: 
 
1. Enable Track Recording 

1. Open OsmAnd on your device. 
2. Go to Menu → Plugins. 

o Ensure the "Track Recording" plugin is enabled. 
o If not, tap to enable it. 

 
2. Start Recording a Track 

1. Tap the Menu (three lines or dots, depending on your version). 
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2. Select "Track Recording" or the dedicated button for it (a red circle 
or stopwatch icon). 

3. Tap "Start" to begin recording your track. 
• The app will track your movement and display the path on the map. 
• You can pause and resume recording as needed. 

 
3. Stop and Save the Track 

1. Once you're done, return to the Track Recording menu. 
2. Tap "Stop". 
3. Save the track by giving it a name and choosing a folder (e.g., "My 

Tracks"). 
 
4. View and Export Tracks 

• To view saved tracks: 
1. Go to Menu → My Places → Tracks (or a similar section). 
2. Select the desired track to view it on the map. 

• To export the track for use in other tools: 
1. Tap on the track. 
2. Choose "Export" and save it as a GPX file. 

 
5. Manually Create a Track 
If you want to create a route (track) manually: 

1. Tap Menu → Route Planning. 
2. Add waypoints by tapping points on the map or searching for 

locations. 
3. Save the planned route as a track for later use. 

 
Tips for Creating Tracks 

• Use Points of Interest (POIs) to add stops or markers along the 
route. 

• Customize your recording settings (e.g., GPS accuracy, recording 
interval) under Settings → Track Recording for better results. 

 

 

Tips for Creating Tracks 
• Use Points of Interest (POIs) to add stops or markers 

along the route. 
• Customize your recording settings (e.g., GPS accuracy, 

recording interval) under Settings → Track Recording for 
better results. 
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Accuracy 
The accuracy of track recording in OsmAnd depends on several factors, 
such as GPS signal quality, device hardware, and settings. Here's how to 
ensure the highest accuracy when creating a track: 
 
1. Optimize GPS Settings 

1. Enable High-Accuracy GPS Mode: 
o On your device, go to Settings → Location (or similar). 
o Set Location Mode to High Accuracy (uses GPS, Wi-Fi, and 

mobile networks). 
2. Use External GPS Receivers if your device's GPS isn't reliable. 

 
2. Adjust OsmAnd Track Recording Settings 

1. Go to Menu → Settings → Track Recording Settings. 
2. Optimize these parameters: 

o Recording Interval: 
▪ Time-Based: Set to record every 1 second for high 

precision. 
▪ Distance-Based: Set to record every 5 meters or less. 

o GPS Accuracy Threshold: Reduce the threshold to a smaller 
value (e.g., 5 meters) to exclude imprecise points. 

 
3. Improve Signal Reception 
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1. Clear Sky View: Ensure there's minimal obstruction (e.g., buildings, 
trees). 

2. Avoid tracking indoors or in areas with poor satellite visibility. 
3. Enable Glonass or Galileo (if your device supports it) for additional 

satellite systems. 
 
4. Use OsmAnd Plugins 

• The "Track Recording" plugin in OsmAnd is designed to handle GPS 
data more efficiently. Make sure it’s enabled. 

 
5. Monitor GPS Accuracy During Tracking 

1. Tap on the GPS icon or location status to view current accuracy. 
2. Wait for the GPS accuracy to stabilize before starting the recording 

(e.g., below 5 meters). 
 
6. Post-Processing 
If your track includes inaccurate points, you can: 

1. Edit the track using tools like QGIS or GPX editors. 
2. Use OsmAnd’s "Snap to Roads" feature for smoother tracks when 

appropriate. 
 

 
 

Downloading data and importing to QGIS 
The simplest method is to export a profile with the necessary data: Menu → 
Settings → Export → select the data that you want to export. Alternatively, 
you can backup all your data from the previous device by copying the 
folder located in Settings → OsmAnd Settings → Data storage folder 
(default path: Android/data/net. 
 
To download data from OsmAnd and import it into QGIS, follow these 
steps: 
 
1. Recording or Collecting Data in OsmAnd 

1. Record Tracks: 
o Enable the Track Recording Plugin. 
o Record your movement or manually create a route and save it. 

2. Save Points: 

Expected Accuracy 
• With optimal settings, you can achieve 2-5 meters 

accuracy in open areas. 
• In urban or forested areas, expect less precision (5-20 

meters). 
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o Use the "Add to Favorites" or "Save Point" feature to save 
specific locations. 

3. Export Data: 
o Go to Menu → My Places → Tracks (or Favorites, if you saved 

specific points). 
o Select the track or points you want to export. 
o Export them as GPX files. 

 
2. Transfer Data to Your Computer 

1. Export via Email or Cloud: 
o Share the exported GPX file via email, Google Drive, or other 

cloud services from your mobile device. 
2. Direct Transfer: 

o Connect your phone to your computer using a USB cable. 
o Navigate to the OsmAnd directory (usually under Internal 

Storage/OsmAnd/tracks). 
o Copy the GPX file(s) to your computer. 

 
3. Import Data into QGIS 

1. Open QGIS on your computer. 
2. Add Vector Layer: 

o Go to Layer → Add Layer → Add Vector Layer. 
o Choose File as the source type. 
o Click Browse and locate the exported GPX file. 

3. Select Data from GPX: 
o When importing a GPX file, you may see options like: 

▪ Waypoints: Saved points of interest. 
▪ Tracks: Your recorded path. 
▪ Routes: Planned routes. 

o Select the layer(s) you want to load and click OK. 
 

4. Customize and Analyze the Data 
• Style the Data: 

o Right-click on the layer in the Layers Panel and select 
Properties → Symbology. 

o Customize the color, line style, or marker shape for better 
visualization. 

• Attribute Table: 
o Open the Attribute Table to view metadata (e.g., time stamps, 

elevation). 
• Perform Spatial Analysis: 

o Combine your imported GPX data with other GIS layers (e.g., 
satellite imagery, administrative boundaries). 

 
5. Optional: Reproject the Data 

• GPX files are usually in the WGS 84 (EPSG:4326) coordinate system. 
• If needed, reproject the layer to match your project's CRS: 
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o Right-click on the layer → Export → Save Features As. 
o Choose the desired CRS (e.g., UTM). 

 
6. Download OpenStreetMap Data (Optional) 
For a more detailed base map: 

1. Use QGIS's QuickOSM Plugin: 
o Install it via Plugins → Manage and Install Plugins → 

QuickOSM. 
o Query and download OSM data for specific areas directly into 

QGIS. 
2. Or, download OSM data in formats like .PBF or .OSM from platforms 

like Geofabrik and load it into QGIS. 
 

Exporting and importing Google Earth data into OSMAND 
1. Export Data from Google Earth 

1. Open Google Earth Pro on your computer. 
2. Create or Select Data: 

o Create points, paths, or polygons using the drawing tools. 
o Right-click on your created features in the "Places" panel and 

choose Save Place As.... 
3. Save as KML/KMZ: 

o In the dialog box, choose KML (Keyhole Markup Language) 
format. 

o Name the file and save it to a known location on your 
computer. 

 
2. Import Data into OSMAND 

1. Transfer File to Mobile Device: 
o Connect your phone to the computer and transfer the KML file 

to a known folder on the phone. 
o Alternatively, use cloud storage or email to send the file to your 

device. 
2. Open OSMAND App: 

o Launch OSMAND on your phone. 
3. Import the KML File: 

o Tap the Main Menu (three horizontal lines) in the top-left 
corner. 

o Select My Places or Favorites. 
o Tap the Import button (folder icon with an arrow). 
o Navigate to the folder where the KML file is stored and select it. 

4. View Imported Data: 
o After importing, your Google Earth data should appear on the 

map as favorites, tracks, or waypoints, depending on its 
content. 
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3. Field mapping with QField  

Introduction to QField 
Open QField on your mobile device and explore the app as we go through it below.  

Open a QField project 

- search for and open the QField app on your smartphone  
- On the first screen you see, choose open local file > sample projects > Bee Farming 

Below you see screenshots of the welcome page and the project page with layers in QField 

 

- If you work with a cloud projects, it is opened by choosing QField cloud projects. 

Main menu is available from this symbol  in upper left corner 

- It display maplayers and main options, including settings (1) and choice between browse 
and digitize mode (2) 

-  

Settings (1) – this is where you choose different settings for QField 

- General  
o Fast editing mode – when activated it provides auto-save like functionality  
o Allow finger tap – when activated editing with fingertapping is possible  
o Maximized attribute forms – convenient to activate if the project has long forms 

- Positioning 
o Activate accuracy indicator – will show the signal quality 

- Variables 
o Nothing needs to be adjusted here 

1 2 
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Navigation in the map 

 Use fingers to zoom in/out, or + / - button  

Activate GNSS 

 Tap positioning symbol in lower right corner  to activate the internal GNSS – hold 
symbol to see options like settings and enable/disable positioning. 

 

Locking/Unlocking coordinate cursor 

 Tap/untap coordinate cursor symbol  to lock/unlock the cursor to the GNSS 
position in the map display. If the coordinate cursor is locked, a new observation will be added 
at the GNSS location. If the coordinate cursor is unlocked, a new observation can be added 
anywhere in the map. You select the position by moving the cursor/map to the position of 
interest.  

Adding features 

- Digitize mode must be activated in the main menu  
- Choose layer to be edited by marking it in the layer panel  
- Use green + symbol in lower right corner to start editing; 

a cross hair cursor will appear. Press to add feature 
- Fill form that appears and press tick mark in upper left 

corner to save.  

Practical Task 

• Explore the map and functionality in the app on your own 
• tap on points and polygons and see what kind of information is stored 

• add features to the Apiary layer 
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• notice the type of information and how it can be added to the survey form, for 
instance for  

• number of boxes: 
• species of bees:  
• beekeeper 
• infected 

 

Further information 

If you want more information about QField, this presentation online gives a nice overview: 

https://docs.google.com/presentation/d/e/2PACX-
1vTpKzkE5hNacnM2vs1n474ataaNl1_jALcdHSrTGcRGaQBCnG3pSUCNhGS8XMd55ubEN9qtXa
xTkjm3/pub?start=false&loop=false&delayms=3000#slide=id.g19d62a80706_0_326 

 

You will also find documentation of QField at https://docs.qfield.org/ 

 

  

https://docs.google.com/presentation/d/e/2PACX-1vTpKzkE5hNacnM2vs1n474ataaNl1_jALcdHSrTGcRGaQBCnG3pSUCNhGS8XMd55ubEN9qtXaxTkjm3/pub?start=false&loop=false&delayms=3000#slide=id.g19d62a80706_0_326
https://docs.google.com/presentation/d/e/2PACX-1vTpKzkE5hNacnM2vs1n474ataaNl1_jALcdHSrTGcRGaQBCnG3pSUCNhGS8XMd55ubEN9qtXaxTkjm3/pub?start=false&loop=false&delayms=3000#slide=id.g19d62a80706_0_326
https://docs.google.com/presentation/d/e/2PACX-1vTpKzkE5hNacnM2vs1n474ataaNl1_jALcdHSrTGcRGaQBCnG3pSUCNhGS8XMd55ubEN9qtXaxTkjm3/pub?start=false&loop=false&delayms=3000#slide=id.g19d62a80706_0_326
https://docs.qfield.org/
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QField - Designing customized forms 
The design you just explored in QField is set up in QGIS. The type of information you can fill in a 
form is decided by the aims of your fieldwork. In this section you will learn how to make layers 
with fields that can contain exactly the information you want to collect. 

When you specify the fields needed, it is important to choose the correct data type. Data type 
decides which type of information that can be saved in the field. If for instance you want to add a 
textual description, the field must be of data type text (string). For more info, revisit video 
PLANNING FIELD MAPPING.  

You can add as many fields as you like in a layer, and with any combination of data types. As 
mentioned above this is decided by the aims of your field mapping project.  

In addition to the fields you specify, there is one field that always needs to be present in a layer. 
This field is automatically generated by QGIS when you make a new layer and is called FID. This 
gives a unique code for each feature that is added to the layer. If you use a notebook to add 
additional observations during fieldwork, note this unique FID down, as this will be the key to 
connect notes to your spatial data. 

Making a GeoPackage database  
In order to use QField for field mapping, you have to design your own survey form. That means to 
decide which features that shall be mapped, like you just have explored with the Bee Farming 
project in QField. The process for doing so is explained below.  

As mentioned above, the geopackage format is a database that can contain several layers in one 
package. It is therefore convenient to use together with QField. You will now create a 
geopackage with a vector layer. You will also prepare the attribute table with the set of columns 
(also called fields in GIS) that is needed for storing attributes for your fieldwork observations.  

• For this training, make a new folder in your SNAC_workshop folder called 
QField_training and save all data there. 

• Open a new project in QGIS and save it as fieldmapping.qgz from main menu > Save as 

To create your own GeoPackage navigate to New GeoPackage Layer in the Toolbar.  
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A new dialogue will open, where you have different setting options.  

 

First, specify where you want to store your GeoPackage and choose a suitable name of the file. 
The file extension for geopackages is *.gpkg. A geopackage can contain many layers. The name 
of the layer is given under “table name”.  

• Name your database fieldmapping and set Table name to survey. Store it in the folder 
QField_training that you just created 

Under Geometry type you choose which type of geometry you want to map. This depends on 
how you have decided to represent your geographical features at the scale you are working on. 
For instance, is it points (e.g. trees), lines (e.g. roads) or polygons (larger areas of e.g. buildings or 
ponds). See video Planning field mapping for more information about representations. 

In this case, choose points. 

Now you can set the desired Coordinate Reference System (CRS) (See video FIELD MAPPING 
USING MOBILE APP). In Sudan WGS84 zone 36N or 37N is appropriate; 37N fits best in the 
east!. These systems are projected in meters. You can also use WGS84 that will give positions in 
latitude and longitude.  
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Under the New field section, you can specify which fields you need in your attribute table 
and which data types they should contain. 

Assign a name, data type (Text, Integer, Decimal, Date …) and click on „Add to fields list“.  

In the table below you are given an example of a simple attribute table for a general field survey 
form.  

➢ What information is needed depends on the features you want to map! 
➢ Also note that the space available for the name of the field is limited 

 
Name Data Type purpose 
type Text (string) Define broad classes of observation 
comment Text (string) Add additional information about your observation 
picture Boolean Tick if you have taken a picture. This can be handy if 

you have an additional camera that is used. In that 
case another field with picture name could be 
recommended.  

measurement  Decimal (double) A field where a measurement can be added. It allows 
decimal numbers to be stored. The data type Integer 
also allows numbers to be stored, but without 
decimals.  

date Date & time To record date and time. Should always be part of 
your form. It can also be used to link other 
information, like sound recordings or videos 

mapper Text (string) Name of mapper / fieldworker 
 
Here is an example of what it should look like for this training:  

As soon as you are done with the fields 
you can confirm by clicking OK. 

Remember to save your project every now 
and then. 

Now the geopackage is ready to be 
further formatted before use in QField.  

Customizing fields with 
appropriate datatypes 
In this part you will learn how to add and 
edit fields in the attribute table and add 
useful settings that can help streamline 
your mapping in field. This includes 
functionality that you have seen in the Bee 
Farming project, like selecting predefined 
classes (species) from a list.  
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Edit existing fields and create new ones 
Open the attribute table to inspect the fields it has now.  

• Mark layer in layers panel > right click > open attribute table 

In order to get an overview of the settings for each field, open Fields in Layer properties:  

• Mark layer in layers panel > right click > layer properties > Fields 

 

Type and Type name refers to the data type for each field.  

In the fields view you can edit field names and add and delete fields from the toolbar: 

• Now, if necessary, edit your fields until you have the same fields and datatypes as in the 
above image.  

Notice that in existing fields you can only change Name. 

For an overview of what the intention with the different fields are, revisit the table in the section 
above.  

When you have all the above fields, the next step is to define how the fields should be filled. 
This includes choices like automatic filling of values (useful for automatic date and time, or 
running numbers) and defining codes/allowed values from a dropdown menu (useful for avoiding 
typo-errors and unwanted values). 

Such refinements are available from Attributes Form in the properties window. You will become 
familiar with the options here through the steps below.  

 

1          2        3 

1 Add field 

2 Delete field 

3 Start editing 
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Add running, unique IDs in a field 
Choose fid from the list under Fields (1) 

Under Widget Type (2), choose Text Edit, and under General tick Editable, as seen in figure 
above 

Widgets allow you to edit data in various different ways. You will be familiar with more of them 
below. 

Under Defaults > default value (3), type $id   This code ($id) automatically generates running ids.  

Add automatic date and time in a field 
Choose date from the list under Fields (1) 

Under General, untick Editable. This will make it impossible for someone to change the date. In 
some cases, it can be good to know when an observation was first registered.  

1 

3 

2 
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Choose the widget type Date/time and fill it like this: 

 

Under Defaults, fill it like this 

 

The code now() generates the date and time for this moment.  

Add default values in a field  
Choose type from the list under Fields 

• Under Widget Type, choose Value Map 

This tool allows you to define allowed values. You must give a Value and Description. Value is 
what will be stored in your attribute table, Description is the choice visible for the mapper.  

Use this table to fill in the Value Map: 

Value Description 
Other Other observation 
Cult_heritage Cultural heritage 
Botany Botany and vegetation 
Landscape Landscape observation 
Hydrology Hydrology and wells 

 

• Under constraints, tick not null (5). This reminds the field to be filled by the mapper. 

Add checkbox 
Choose picture from the list under Fields (1) 

• Under Widget Type, choose Checkbox 
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Other useful settings 
mapper field:  

If several persons use the same layer for mapping, it is convenient to add the name of the 
mapper. In this example we use data type text and the name has to be typed in for each 
observation. Luckily it is possible to avoid repetitive typing of names: 

• Under General, tick “reuse last entered value” 

 

• Under Constraints, tick both “Not null” and “Enforce not null constraints” – this forces 
the mapper to fill this field. Notice the difference between “Not Null” and “Enforce not 
null constraints” 

 

• Finally for the field measurement, choose widget type text edit. This allows the mapper 
to type in the measurement. You can also explore the range widget that is another 
possible widget for data type decimal (double) (Real).  

Designing attribute forms 
In this section you will learn how you can organize the requested input information in a tidy and 
organized manner. The design you generate in QGIS will be what you get in QField.  

In Attributes Form, change from Autogenerate to Drag and Drop Designer in the upper part of the 
window (1). A new panel appears called Form Layout. This helps create a structure with groups 
of data input under headings that you decide.  
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The plus and minus buttons (2) add and remove groups/levels in the layout. Fields can then be 
dragged and dropped under the group labels.  

• Start by adding a group (plus sign) called Required 
• Drag and drop the fields mapper, type and picture below it 
• Add another group called Additional 
• Drag and drop the fields comment and measurement below it 

You don’t have the relation called point_pictures in your dataset, so you can skip that. This will 
be added in Part 5 and is used to add pictures to your database. 

Add basemap and layers to project 
So far you have not added any basemap to your project.  

• Add google satellite basemap in the same manner as you did in Part 1 Adding basemaps 
via plugins.  

• In addition, we will add an offline 
version of google satellite of the 
field area in Arbaat 

o Go to Layer > add layer > 
add raster layer 

o Navigate to the folder 
Data/Part3/basemap/ and 
select the file arbaat_concession.mbtiles 

o Click ok 
o If you turn off the google satellite basemap you’ll see the extent of the layer you 

just added. Zoom to layer if needed (right click layer > zoom to layer) 
• If necessary, rearrange the layers.  

1 

2 
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Add test points and define symbology 
In QField the features you add will be displayed on the map with the same symbology as you 
have defined in QGIS. Now you will test your setup by adding one point for each of the types you 
have defined.  

On the Digitzing toolbar, make the layer editable  and use the add points tool  to add 
points  

 

Check that adding information works as expected compared to the widgets you have added 
above.  

When done, save changes  and check in the attribute table that you have one feature for 
each type (i.e. 5 points) 

Open the symbology window from the layer properties and use the type field as Value to 
symbolize your features. Click OK when done.

 

To make it easy to keep track of recorded observations, it can be good to activate labelling. This 
will label each point with, for instance, a unique code as stored in the column fid. 

• Go to layers panel, select survey layer and right click > 
select Show labels 

• Open layer properties > Labels and fill like this to label 
observations with fid 
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Tracking 
Tracking your movement is very convenient when you are working in field. You can track your 
movement either in a point feature layer or in a line feature layer. When you start tracking in 
QField, you can decide how often you want your position to be stored. The frequency depends 
on how much detail you need, and how fast you are moving.  

If you save your track to a point layer, each point can store date and time1. This is very useful, for 
instance if you take pictures or record videos or sound that do not have a geotag. In such cases 
you can connect such recordings to your track via the date and time information.  

In this example, you will prepare a point layer for tracking.  

Create a new point layer in your geodatabase as you did earlier in the exercise (Making a 
GeoPackage database). Call it tracking. 

• Add a new field that can 
store date and time. 
When you click OK to 
create the layer, choose 
“Add new layer”.  

 
• In the attributes form, define the date widget as we did above (Add automatic date 

and time in a field). 
• To avoid the form 

popping up each time 
a new point is added, 
choose “Hide form on 
add feature” in upper 
right corner.  

• Click apply when you are done. If needed save your edits.  

In QField you start tracking by long-pressing on the tracking layer. This 
window will appear where you can choose to track by time or distance: 

 

You can read more about tracking here: https://docs.QField.org/how-
to/tracking/ or in the supplied pdf-file: Data/Documents/Tracking - QField 
Ecosystem Documentation.pdf 

Practical Task:  

If you have time, design a new layer (polygon, point or line) with 
customized fields and a form that can be useful in your field of studies. PS 
! This can also be done later when you have more time       

 
1 If you track as a line, the line will receive date and time information when you start tracking. Each vertex 
(point on the line) can store M-values (has to be chosen when you create the layer), which means seconds 
since tracking started.  

 

https://docs.qfield.org/how-to/tracking/
https://docs.qfield.org/how-to/tracking/
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From QGIS to QField 
We are nearly there!  

Before exporting your project to QField, make sure you save the latest version. If you have any 
layers in the project that you don’t want in QField, remove them from the project. 

The following layers should be in your project: 

o Survey (from fieldmapping.gpkg) 
o Tracking (from fieldmapping.gpkg) 
o Arbaat_concession.mbtiles (raster layer) 

Save again if necessary.  

Configuring offline basemap 
The raster layer Arbaat_concession.mbtiles makes it possible for us to have a high resolution 
basemap offline during fieldwork.  

PS! You can create this file on your own for any area of interest, as explained in Part 5: 
Generate basemap for offline mapping. 

Since this raster layer is a large file (for instance too large for QFieldCloud, see Part5), we need 
to set one setting in QGIS and manually copy the file to our mobilephone.  

o Go to Settings > Options > In the window, locate Data Sources > Localized Data Paths 
o Use the + - sign and navigate to the folder where the mbtiles-file is stored (folder 

Part3/basemap) in order to add the path. It should look something like this (the exact 
path will vary from computer to computer) 

 

o Click OK 

 

Transfer of project via folder import / export 
There are different ways to transfer your project to your mobile device.  

1. Transfer a folder with all project content to the device using e.g. a cable 

In this way we tell QField to look for a copy of this file on the mobile telephone in an internal 
folder called basemaps under QField 

PS! You must copy the raster file to your mobile phone. Follow these steps 

- Connect your mobile to the computer 
- Navigate to this folder on the mobile 

o /Android/data/ch.opengis.qfield/files/QField/basemaps 
- Copy Arbaat_concession.mbtiles to this folder 
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2. Transfer the project using QFieldSync Plugin, either with a cable or via a cloud solution 
(QField Cloud). 

What we recommend in this course is option 1. Option 2 is explained in detail in Part 5.  

Before you transfer your working folder (should be Qfield_training in your case) make sure that all 
your layers are stored in that folder.  

Use file explorer to see the content of the folder. It should contain: 

• Fieldmapping.gpkg and  
• Fieldmapping.qgz 

Save and close your QGIS project.  

Now transfer the project by following these steps: 

• Copy the Qfield_training folder to your mobile device, e.g. 
by using a cable. Note where on the device you save the 
folder. 

• Open Qfield and choose > Open from local file  
• Press + symbol > import project from folder > navigate to 

the location where you saved your folder and press “use 
this folder”, and if needed accept Qfield to access files in 
the folder by pressing Allow 

• You will see an overview of the imported content and can 
open the project by pressing the name of the project; 
fieldmapping 

• The project opens and you are ready to start collecting 
data.  

PS! Before going to field check that everything works as expected 
by adding some test observations. 

Getting data from device to computer 

If you don't have any attachments (pictures etc; see below if you do) stored in the geopackage, 
the easiest way to export the data is to open the project in QGIS, choose Settings > Project folder 
> press the 3 dots behind the geopackage name and choose one of the options there: 

• Send to – this will send the file using any of the apps on your device, e.g. whatsApp 

• Export to folder 

• Navigate to the folder where you want to save your geopackage. If needed, create 
a new folder.  

• Connect your phone to the computer and transfer the file.  

Getting data from device to computer when you have attachments: 

If you have added attachments to any layer, they are stored in a separate folder called DCIM. To 
get all the data, pictures and geodata in one go it is recommended to export all the data 
belonging in the project to a folder. 
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Connect the phone to your computer. On the phone's storage, create a folder called 
Qfield_export. 

If Qfield is open, close and reopen it. On the front page, choose open local file > Imported 
projects >  press the three dots behind your project name (same name as your original folder 
name) > Export to folder > Navigate to the Qfield_export folder you just created > select "use this 
folder" and accept any questions about permissions.  

Now copy that folder to your computer and open the qgis-project file inside it. 

Some tips about working with field data after fieldwork 
When you are back from fieldwork you typically want to analyse and visualize your data, and how 
you can make a map is explained in more detail in the next section. But it is important work after 
fieldwork to go over and control the quality of your data and correct any obvious errors. 
Unfortunately, there is not time in this workshop to cover this, but here are some tips with links 
to more information: 

• inspect all the collected geographical data to make sure there are no obvious errors, like 
points/features outside the field area. If possible, reposition them by editing the layer. You 
can read more editing/digizing here: 
https://docs.qgis.org/3.34/en/docs/user_manual/working_with_vector/editing_geometry_att
ributes.html#digitizing-an-existing-layer 

• inspect your attribute table for errors, like obviously wrong measurements or spelling 
mistakes etc. You can symbolize the data using any of the columns and this can give a clue 
about possible mistakes. You can also sort the columns in increasing/decreasing order to 
see if values are in expected range. If you need to edit data in the table, start editing by 
choosing the pencil symbol.  

o PS! If you edit your table, always remember to keep a copy of the original version!  
• You might have notes in a notebook that you want to include in your attribute table. You can 

create a new field (as you did when you made the survey layer) and add info manually by 
punching your notes into the attribute table. An alternative way is to write up all your notes in 
e.g. Excel and save it as a delimited text file, and import the table to QGIS and use the join-
tool to connect this table with the attribute table. In either cases, you will have to use an 
identifier to connect the two. In most cases, this will be the column fid; that’s why you should 
also note the fid down if you make handwritten notes for an observation 

o Importing delimted text file: 
https://docs.qgis.org/3.34/en/docs/user_manual/managing_data_source/opening_d
ata.html#index-9 

o Joining table to attribute table: 
https://docs.qgis.org/3.34/en/docs/training_manual/database_concepts/queries.ht
ml#joins 

• If you have geotagged photos from field work, they can also be imported in your GIS-project. 
Here’s an explanation of how: https://mapscaping.com/adding-geotagged-photos-to-qgis/ 
 

https://docs.qgis.org/3.34/en/docs/user_manual/working_with_vector/editing_geometry_attributes.html#digitizing-an-existing-layer
https://docs.qgis.org/3.34/en/docs/user_manual/working_with_vector/editing_geometry_attributes.html#digitizing-an-existing-layer
https://docs.qgis.org/3.34/en/docs/user_manual/managing_data_source/opening_data.html#index-9
https://docs.qgis.org/3.34/en/docs/user_manual/managing_data_source/opening_data.html#index-9
https://docs.qgis.org/3.34/en/docs/training_manual/database_concepts/queries.html#joins
https://docs.qgis.org/3.34/en/docs/training_manual/database_concepts/queries.html#joins
https://mapscaping.com/adding-geotagged-photos-to-qgis/
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4. Making a final Map Layout of the field area 
In this section you will learn how to make a final map representation of your field data. It builds 
on what you learnt in part 1: Create a Layout 

 

Creating an overview map of Sudan 
In the Data folder navigate to Part4/Natural_Earth_quick_start/ and locate the QGIS project file 
(Natural_Earth_quick_start_for_QGIS.qgs) and double-click to open it. 

 

When opened, the project will look something like this (note that the colours may be different): 

 

For future projects: You can add any wanted vector data via the Data source manager.  
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Zoom the East coast of Sudan. 

It can be a bit distracting if every layer is activated. Go 
ahead and try turning some off until you think the amount 
of information is right and the visibility is good.  

You can also re-arrange the order of the layers by dragging 
the ones to the top of the list, that you want to display on 
the top. 

Identify the layers you want to include in your overview map 
and symbolize them as explained in Part 1: Changing Layer 
Symbology.  

• Change the layers you want to use into sensible 
styles and colours.  

Open a new print Layout by going to Project → New Print Layout and give it a title, for example, 
Sudan_Layout. A new window will open.  

 
 

When clicking Add item → Add Map you can choose the area of the canvas which should be 
covered by the map by drawing a rectangle. You will need space outside the map for text or other 
elements. 



SNAC workshop – Field mapping and GIS 

53 
 

 

Since this map is not going to be the man focus, you can leave it rather small. We will add 
another map and other elements in the next steps.  

 

 

Click on the map once and you will see that a pane called Item Properties opens on the right 
side. Here you can adjust certain properties such as scale or CRS. 

Now we want to insert another map. Before doing so, make sure that the layers and their styling 
are locked so that we can insert a second map on top the first map without affecting the first 
one. 
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Adding a map of your field area 
We often wish to have multiple maps displayed on a graphic or page, for example, with an inset 
map that shows the general location for an area displayed in greater detail. We’ll create such a 
map in learning the rudiments of layout styling. Go back to the QGIS main window and zoom in 
to the area you want to highlight. In this example we have used Port Sudan, but you should 
zoom into the field area you have visited.  

 
 

Now add another basemap from QuickMapServices tool. Open the tool and select Google 
satellite.  

PS! You can also use the Search QMS tool. The panel will be activated on the 
right side of QGIS main window. Here Search for Google Satellite and click add. 
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Make sure that Google Satellite basemap is visible, either by putting it on the top of the layer list 
or by adjusting the ordering and visibility of other layers.  

PS! If you don’t have wifi, add the Arbaat_concession.mbtiles layer and use it as a 
basemap.  

Now add your field data to the project: 

• It is explained how to add data from OSMAnd in the section: Downloading data and 
importing to QGIS. 

• Data from QField is added by locating your updated geopackage (see section: 
Synchronize cloud projects after fieldwork and/or Exporting back to the QGIS) and use 
the add vector layer tool to add them into the project. 

 

• Symbolize the added vector layers appropriately and zoom to the extent of your choice.  
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Now, go back to the Print Layout Window and add a new map the same way you did with the 

first one (Add Item → Add Map or you can use the Add Map tool  from the toolbar). 

We will now add other map elements to complete the map layout: legend, scale bar, title, north 
arrow and source (CRS).  

• If you don’t remember how to do this, revisit Part 1: Create a Layout where this is 
explained. 

Add legend: When adding a legend, note that you can rename your layers in the main window, 
so they appear nicer in the legend by clicking on Edit selected item properties: 

 

Add scale bar  

Add Label /Title  and adjust font and font size  

Tips: 

Use this tool from the toolbar to move your map in the map frame. When 
you are satisfied, click on the white hand that is used to navigate the 
elements of the layout. 
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Add North arrow . Most north arrows do 
not contain an “N”, in order to consider 
languages that do not use “North” / “N”. 
Accordingly, we manually add “N” to the 
arrow. Click on Add Label to create a text 
element. Just write an “N” into the text field on 
the right and set a proper format, e.g. allign the 
letter in the middle and choose a suitable font 
(see picture to the right). Hint: you need to 
click on the font field to be able to change it. 

It is convenient to group the north arrow and 
the “N” together, so that they will be treated as one element. Mark both by typing Crtl and left 

clicking on each element. Go to Group items in the main icon bar at the top.  

The group will appear in the Items window (blue box) . 

 

 

Add map grids showing the coordinates. You can do it by selecting one of your maps by clicking 
on it → Item properties window → Grids. Add grid by clicking the Plus sign and then Modify 
Grid. Play around with interval till you find an interval that fit the extent of your map layout.  
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Change the line color to gray to make the grid less dominant in the layout, but so that it is still 
visible.  

 

 

Note: 

The map grid is used for locating places on the map accurately. It consists of vertical 
and horizontal lines that create a grid, with each section labelled with a unique 
reference. This enables users to pinpoint exact locations using coordinates, facilitating 
navigation, planning, and geographic analysis. It should not hinder to read the map.  
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Further down the list in the Item Properties, tick Draw Coordinates box. This will add 
coordinate labels. Adjust the parameters so that the labels look good. 

 

Add a label with text about data source, CRS and projection used for the map as well as the 
author.  

Lastly, we want to indicate the location of the detailed 
map in the overview map. In the Items window, mark the 
item Map1.   

Go to the Item properties tab and scroll down to Overviews.  

• Click the + sign, and tick the box “Draw “Overview 1” Overview. In the Map frame 
dropdown, select Map 2.  

If your zoom level is appropriate, it is marked out where your detailed map is located in Map1 
map frame. If you change the zoom level in the detailed map layout, the overview indicator will 
change accordingly.  

• In the Frame style, you can edit the style of the frame to for instance a red outline as seen 
below.  
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You are now ready to export your map as a pdf or another format of your choice 

Click on the Export as PDF… icon in the toolbar on top. Recall the instructions from Part 1.  
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5. QField – More to know 
Adding attachments like pictures, videos and sound recordings 
We can use the widget type attachments to add pictures to our field recording. For this we need 
to have a table where the path to all our pictures is stored. We also need to add a relation 
between this table and the main layer for the mapping, in this case our point layer. 

Add and format fields of the table layer 
Add a new table layer to geopackage 

- Main meny > layer > create layer > new geopackage layer 

Fill it as described in the picture below 
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Now open Properties > Attributes Form of the Table layer 

For field id, type uuid() in the defaults field 

 

Do the same for the picture_id field. 

 

For path set widget type to attachment, and fill as shown below. Notice in the next image that 
the integrated document viewer is set to type image. This allows the image to be displayed in 
QGIS/QField when you use click on a point of interest. 
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Add relation  
For keeping track of which pictures (stored in the table) belongs to which feature, we need to 
make a relationship between the table and our feature layer. A relation is created using a unique 
ID that is shared between the two datasets. In our case the unique ID are created above with the 
uuid() expression.  

Relations are set up in the project 
properties. 

Main menu > Project > properties > 
relations > add relation  

Fill the window like shown to the right. 

 

The next step is to add this relationship 
to the feature layer.  

Open the properties dialog and the 
attribute form of the point layer. The 
relation you just created is visible 
under relations. Drag and drop the 
relation point_pictures into your Form 
Layout. 
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Generate basemap for offline mapping 
In this section you will learn how to generate maptiles that can be exported to QField for use in 
offline mode. 

When you work in areas without coverage it is very useful to have a background map, i.e. 
basemap, available offline. By offline we mean that the basemap is stored as a local copy on 
your device (smart phone). The basemap will be stored as so-called tiles. It means that the map 
of your area of interest is divided into several small maps, i.e. tiles, and the same is done at 
multiple scale levels. Tiling makes zooming in and out in the map fast. Each tile generated is an 
image, typically in jpeg og png-format. Maptiles retain geolocation from the original map source. 

There are different plugins in QGIS that can convert background maps into tiles. In this exercise 
we will use QMetaTiles that you have already installed.  

Generate tiles from a basemap.  
The basemap you want to use in QField has to be displayed in your map. In this example you will 
use Google Satellite as basemap. 

TIP: When using the default options in QField, pictures will be taken with a minimalist internal 
camera. The advantage is that this allows geotagging of images. If you want more camera 
options you can choose to use the native camera of your mobile phone. However, this does 
not allow geotagging within QField. If you need geotagged images and want more camera 
options, you need to install the Open camera app. You can default settings in QField under 
settings > general > Advanced. The open camera app will have to be installed on the smart 
phone.  
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Locate the QMetaTiles tool on the toolbar and press to open:    

This window will appear: 

 

Here follows an explanation of the settings and what to select: 

• Tileset name: change to the same as your background map, e.g. Google maps.  
• File – click browse. In the new window  

o Navigate to your working folder 
o File name: Specify an appropriate name, e.g. Googlesat_background 
o Save as type: Choose MBTiles databases 
o When done, click save 

• Extent – different options to delimit extent of the tiles. 
o Zoom to your area of interest and choose canvas extent 
o Canvas extent is recommended when your canvas is fitted to your area of 

interest in the map window,.  
o Layer extent is recommended when you have a layer outlining your area of 

interest 
o Full extent is not recommended when the background map has a global coverage 

• Other settings can be kept with default values. Here’s a short explanation of what the 
most important ones mean 

o Minimum zoom – this is the coarsest scale that tiles will be generated at.  
o Maximum zoom – this is the finest scale that tiles will generated at. This is the 

one you like to have as high as possible. But higher number also means more 
tiles and bigger files. Filesize is often a limitation, especially if your area of 
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interest is large. A good balance between between map details and filesize is 
needed. 

o Tile width and height – sets how many pixels each tile is in x and y direction 
o Quality – compression of files, lower value less quality 

Add basemap to your project 
The tiles you just generated are in raster format. Add tiles to your project by choosing Add raster 
layer from the Manage layer toolbar 

 

This can also be done from the main menu > Layer > Add layer > Add raster layer 

In Source > navigate to your working folder and select the Googlesat_background.mbtiles file > 
click Add 

 

The file can also be imported to your project in QField 

Adding tiles to QField 
Tiles can be added to Qfield in different ways.  

The easiest way is to include it in the QGIS project and synchronize it to the cloud with the rest of 
the files in the project. However, if the tile is large, you might get problems with storage space in 
the cloud. If that is the case, the approach describe in section From QGIS to QField 
recommended. 
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From QGIS to QField with QField Sync 
We will use the QField Sync plugin to export our project to our smartphone. Installation of the 
plugin is explained in section: Installation of Plugins needed for the Workshop 

The first step is to set preferences for QField  

main menu > Plugins > QField Sync> Preferences. 

Notice what are the default directories for storing projects. There are two different settings, one 
for cloud projects (QFieldCloud settings) and one for projects that you will manually copy to your 
mobile phone (Packaging settings). Write down the paths so you remember them! 

PS! It is an advantage that the path is not too long, and it should not include any spaces or 
special characters. 

 

 

Configure for cloud synchronization 
Using QField cloud is a very convenient way to export projects to QField. It requires that you have 
wifi connection. It will store a copy of the project in the cloud and synchronize from there to 
QField, and after fieldwork it will update your project in QGIS via the cloud version.  

To use cloud synchronization an account is needed. It can be created from within QField, as 
explained in section: Installation of QFieldInstallation of , or by clicking on the blue cloud symbol 
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and register from there. In either cases, remember to confirm your email address before you 
try to login!  

When you have an account, press the blue cloud symbol and login.  

Now press Configure Current Project  

 

 

Here you define how the project will be exported: 

Prefer offline layers means you can work with your project in field without wifi connection. 
Notice that the vector files survey and tracking now have the Action Offline editing.  

Under Base Map you can choose to export a chosen background map so it can be accessible 
without wifi connection. However, when using cloud synchronization, storage is limited in the 
cloud. That is why we use the alternative approach with setting localized path and copying our 
basemap manually, as explained above.  

Under Advanced settings you can choose to only export what you see in your map extent. It is 
very important to limit map extent if you also choose to create a Base map.  

 

• When settings are fine, click OK 
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• Save your project!  

 

Now, Press the blue cloud to generate a new cloud project.  

 

In the window appearing, press the create new project button in the lower left corner.  

In the next window select the recommended setup:  

 

Notice that you are now going to create a copy of your project that will be saved in the folder 
specified above as default cloud directory.  

This means that you now have two copies of your project 

• The original version in your SNAC_workshop/QField_training folder 
• The cloud version in your default cloud directory 

 

Press next and make an appropriate project and folder names, and press create.  

PS! When you synchronize after field work, changes should be synchronized back to the 
project in the default cloud directory! After synchronization you can copy the geopackage 
file with all your added field observations to a new location. Use this file to make a new 
project to display, analyse and make a final map layout. In this way you will keep the 
original project intact for further edits and adjustments for new field work.  
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After the project is created you will see it in the project overview list.  

Save your project and close QGIS.  

You are now ready to open the project in the QField App.  

• On the first screen, choose “QField cloud projects”.  
• Log in if needed and choose the project from the list under “My projects”. 

Congratulations – you are ready for fieldmapping using QField!  

Synchronize cloud projects after fieldwork 
When you are done with your fieldwork, the project in QField will show a blue cloud with 
updates. Press it and choose either synchronize or push changes. Push changes will push 
updates done in the app to the cloud. This should be sufficient after field work.  
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When you are back in your computer environment, open QGIS and locate your cloud project. PS! 
You ‘ll find it in your default cloud directory! When open, press the blue cloud with arrows to 
synchronize the changes: 

 

 

Here you can decide how to handle the changes. In this case, we want to download the changes 
we have made in the layers (survey and tracking, and possible others you have made on your 
own) in the fieldmapping.gpkg. Click Perform Actions. 

Now you should see the new data in your QField project! And you are ready for further editing, 
analysis or layout creation.  

Configure for cable export 
Skip this section if you have wifi and can use cloud synchronization.  

This section describes the alternative way to export your project from QGIS to QField if you don’t 
have WiFi connection. In this case you will use a cable to transfer the project from the computer 
to the smart phone.  

From the toolbar, choose configure project, and the tab Cable Export in the window that 
appears.  
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On your geopackage layers, choose offline editing. According to the documentation this means 
that: 

“A working copy of the layer is copied into the package folder. Every change which is done in the 
packaged project during work is recorded in a changelog. When synchronizing the changes back 
later on, this log will be replayed and all changes also be applied to the main data base. There is 
no conflict handling in place.” 

If you want to delimit your project to an area of interest, there are different possibilities under 
Advanced settings.  

For more information about configuration, see here: https://docs.QField.org/get-
started/tutorials/get-started-qfs/ or in the supplied pdf: Data/Documents/QFieldSync - QField 
Ecosystem Documentation.pdf 

Click Ok when you are done.  

 

Now you are ready to export.  

From the toolbar, choose Package for QField.  

 

Choose an export folder where your project will be saved. The default folder is ..\QField\export\ 
and name of the folder will be the same as your project name.  

Import project into QField 
Connect your phone to the laptop. Make a folder named QField, and a subfolder called export. 
Make another subfolder called import. You will use the latter when you are done mapping.  

- Copy the fieldmapping folder from your laptop to the export folder on your phone.  
- Open QField, and choose Open local file.  
- Press the + sign in the lower right corner, and choose import project from folder 
- Navigate to the fieldmapping folder, and press use this folder 

When import is done you can open the imported project and start mapping!  

Exporting back to the QGIS 
When you are done mapping you need to do the reverse process.  

Notice that in the imported projects view in QField, there are three dots behind each project 
folder name.  

Press these and choose export to folder.  

https://docs.qfield.org/get-started/tutorials/get-started-qfs/
https://docs.qfield.org/get-started/tutorials/get-started-qfs/
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Save to the import folder that you made above.  

Copy the folder back to your PC and use the Synchronize from QField button on the QField sync 
plugin in QGIS. Navigate to the import folder and press synchronize.  

 

 

 

You are now ready to edit or analyse your data further in QGIS or to make a nice layout for 
disseminating your findings. 
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